Jump to content

97 delsol Engine problem need help NOOB


Demcka

Recommended Posts

Hello, i have this 97 del sol automatic transmission with 150000 miles on it, i was driving the other day and the engine just shut off, and when i tried to start nothing, i can hear the starter engaging but the motor wont turn over, even with jumper cables i get same problem, i do have a oil leaking problem but i alway check to make sure i have enough oil, i had it towed to my house, ive heard that you can check if the motor siezed without even taking it apart by just trying to turn it by the crank shaft pulley, but do both tires need to be off the ground, im a student and dont have much money to deal with it, so if the motor is a gonner i just have to get rid of this car.. please let me know what i can do or look for,

Edited by Demcka
Link to comment
Share on other sites

just slap it in nutrual and try to spin the crank with a wrench. with the litltle info i know about the car it seems odd to have a bad motor at 150k...

 

 

i tried to spin it last night with a socket and wrench and i couldnt, could be that i dont have enough leaverage?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.