Jump to content

ULTIMATE B16A ENGINE PROBLEM PLZ HELP


Recommended Posts

ok here is the run down...

i have a 96 civic ek, i did an engine swap and put in a b16a4 with the corresponding ecu.

 

now my problem is that when the car is cold it will idle at about 1200rpm, as i drive along as i start slowing down to stop when i put the clutch it the idle goes up to 2000rpm or higher then once the car is completely stoped it will slowly drop to around 1500rpm. it will keep doing this even after the car has warmed up.

 

i hav found that once the car has warmed right up if i turn the car off then back on it will run fine.

 

can anyone plz help me figure out what the cause of this problem is :(

 

things that have been checked:

*throttle body

*vaccume leaks

*iacv

*ecu

 

if u can help me fix this problem i will forever be ur servent

 

HELP ME ITS DRIVIN ME CRAZY!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.