Jump to content
Sign in to follow this  
Cnr100

2003 Accord turns off while driving

Recommended Posts

I have a 2003 accord and it lost all power while I was driving. It lost electrical power and the engine turned off. There were no signs that it was losing power before it happened. This has never happened to me before. In the winter I was having issues with the car starting. I had the starter replaced and even got a brand new battery. When I tried to start the car it wouldn't even crank. Has anyone experienced this before? I'm wondering how much this will cost to fix.

Share this post


Link to post
Share on other sites

Did you ever find out what the problem was on your Accord.  Having very similar issue with my 2004 accord. 

Share this post


Link to post
Share on other sites

Checked the battery cable ? It can be corroded inside the insulation: this can sometimes be seen right where the cable leaves the positive terminal. The bare wire surface looks like it has a turquoise patina... Or worse! This will prevent the starter from receiving the voltage it needs to start the engine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.