Jump to content

1991 Honda civic si


brothertime

Recommended Posts

I was replacing the fuel filter on my 91 civic si. I broke the fuel line that goes from the filter to the fire wall. I was wondering a couple of things. First what is it called (part number)?

Second does it goes through the firewall? Third is it a hard job to replace? As always thanks for the help up front.

Link to comment
Share on other sites

  • 2 weeks later...

Okay. I've checked all my sources and come up with nothing.

 

You were told correctly: get the one you have fixed.

 

Take it to a place that makes hoses. Typically a fork lift shop or hydraulic supply shop will have the equipment to fabricate a new hose but you don't necessarily need to look for a hydraulic supply shop, just ask around the auto shops to see if they know of anyone who fabricates fuel lines. The plus side is it will be much cheaper than if you had found the part. What they do is cut the hose crimp off each end and reuse the hard tubing with new rubber and new crimps. Worse case scenario is they don't have crimps that fit those hard lines and end up using something else and brazing it onto your existing hard line. Either way you leave with a new line.

Edited by James Matteu
Link to comment
Share on other sites

Ya I took it to a hydraulic supply shop and they couldn't help me. Luckily one of the guys working there works on Honda's. he set me up itch a guy who is fabbing a new with the old parts. Not cheap but he told me he has done lots of fuel lines similar to this. Should be done tomorrow with any luck. I will let you all know

Link to comment
Share on other sites

  • 2 weeks later...

Yes thank you for all your help here. I got it back, a lil pricey but well worth it to me. Went back together much better and no leaks. Not I am having problems with the main relay. Man what a job getting that thing out. But I did get it out and a new one on its way should be here in a few days. I was going to try to fix it myself but really not that good at soldering.

Link to comment
Share on other sites

Hi everyone and just a lil update. I got the new main relay installed and everything seems fine. Have not had a problem starting it when I warm it up. Now that's I trust it to drive it I noticed it needs a muffler and the idel is a lil low when its all weed up. Looks like it is below 500 on the tack. It doesn't seen like it wants to die but I don't remember it being this low.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.