Jump to content

My 95 civic is missing out badly! help plz


MattIstheShizznit

Recommended Posts

I need help big time! My 95 civic is missing out....its a D15 1.5L non vtec

 

FOLLOWING PROBLEMS:

-doesnt wanna stay running

-backfired three times total after giving it gas

-wierd noise coming from airbox/intake and after it does that it dies and white smoke comes out from airbox/intake

-missing/popping like crazy

 

Following steps I have doe so far but nothings working

-changed fuel pump

-spark plugs

-air filter

 

Plz help me out with any suggestions thanks

Link to comment
Share on other sites

I need help big time! My 95 civic is missing out....its a D15 1.5L non vtec

 

FOLLOWING PROBLEMS:

-doesnt wanna stay running

-backfired three times total after giving it gas

-wierd noise coming from airbox/intake and after it does that it dies and white smoke comes out from airbox/intake

-missing/popping like crazy

 

Following steps I have doe so far but nothings working

-changed fuel pump

-spark plugs

-air filter

 

Plz help me out with any suggestions thanks

 

 

 

 

 

try to unplug map sensor and sensor on back of intake mani see if it will go it should go but it will still run rough im having same problem with my integra

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.