Jump to content

Recommended Posts

I have finally finished building my Turbo B18c1/B16 Head 1993 Civic Hatch, and am running into some issues. 

Issue #1 After it starts up, it will shoot up to 3k rpms, and then down to 500 rpms, and back up 3 times, then it will idle normal, like it should.

Issue #2 : Once I give the throttle 1% input, it will shoot up to 3,000 rpms.

I am currently running the Skunk2 3L Pro Street Intake with the 2L Spacer, and a 90mm KTuned Throttlebody, FIC 2150cc Injectors, and a Bosche 044 running on e85. I have tried adjusting my throttlebody cable so it has some slack, and even adjusting the tps on Hondata so it wouldn't rev up at much, but it didn't change anything. I just would like my car to not try to do a track launch when I am just trying to push the clutch in, and move forward just a couple feet lmao. Someone please help me!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.