Jump to content
AlyyyD

00 Civic EX (vtec) Speedometer issues

Recommended Posts

I recently had a bad Oil leak at the rear main, cam seal, oil pan gasket and valve cover gasket. Brought it to a shop and had them replace the clutch, timing belt and all front and rear seals for the oil leak. Got it back and still had a very minor oil leak.

Took it back and they told me it was the tranny seal they had to tighten everything up and there was no more oil leak. Visually from what i can see the leaks are fixed.

Needless to say I drove it home that day and the check engine light came on with a slight high idle @ about 1500rpms. The speedometer stopped working completely.

Does anyone think it might be the speed sensor on the tranny? And maybe when they were fixing my tranny seal they triggered this sensor? Or what night be causing this?

The car does run a little more rough than usual. Maybe a map sensor? 

 

Any feed back would be greatly appreciated!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.