Jump to content

Not receiving FM stereo frequencies


Recommended Posts

I bought a 2013 Honda Accord Hybrid from Japanese which I exported to Trinidad. Of course the Japanese radio doesn't work in Trinidad so I bought a used radio from an American 2014 Accord Hybrid. I installed the American radio in my Japanese Accord but the CODE wasn't being accepted. I kept getting the message: CODE ERROR. Then I held down the power button on the radio to automatically activate the radio. It began to work and now I'm seeing all the radio features in English as opposed to seeing them in Japanese. This is great.

However, the American radio (which was working fine in the American Accord) still isn't receiving our local FM frequencies. It only scans between 76FM and 90.0FM. Our local frequencies run from 90.1FM to 107.9FM.

What am I doing wrong that's causing this American radio to not go beyond 90.0FM and what can I do to make it work?

I suspect that using the radio's Power button to activate the radio might have bypassed the Code and picked the car's built-in settings but I'm not a technician (obviously) so I'm only guessing. I desperately need assistance with this as I spent a small fortune buying that American radio and I really NEED to receive our local frequencies.

Please HELP. I'm DESPERATE now.


Thank You,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.