Jump to content
Sign in to follow this  
JohnMark

2005 Accord Power Steering Pump Problems

Recommended Posts

About a week ago, my car started making a sound coming from the serpentine belt area. I didn't have much time to investigate it, so I let it go. The noise has gotten progressively worse. Yesterday I opened up the hood and found the power steering pump has been leaking all over the place. I have included three videos: the sound a week ago, the sound yesterday, and the pump leak yesterday.


Videos:

Sound a week ago:

Sound yesterday:

Pump leak yesterday :


Two questions:

1. Do you guys suggest a new pump or rebuild it with the seals from the dealer?

2. Will the belt need to be replaced or can it probably just be taken off and cleaned?


Thanks for the help.

Edited by JohnMark

Share this post


Link to post
Share on other sites

mine does the same thing, i just replaced the belt and its still making the chirping sound. I'm going to replace the pump with a new one and hopefully that takes the sound away.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.