Jump to content

Can u help me?


Recommended Posts

I have a 93 civic Si with a d16z6 recently seems to have lost power. I put just tried putting a new accel(autozone brand) ignition coil. And it still seems to bog. I checked the spark plugs and they still look pretty new. Also I bought new plug wires and put them on they made no difference so I took them back. I also just pulled the air filter off(aftermarket short ram) and soaking it in water and soap, and rinsing it. I'm gonna let it dry over night and hope that helps. Other than that I can't think of anything else besides fuel filter Being clogged? I know it's only a sohc Honda but it seemed to take off better a couple weeks ago. I have reciently had the ac evaporator and expansion valve replaced at a shop. But I don't see affecting the performance. Any imput would help thanks.

Link to comment
Share on other sites

i see that u did a tune up but have u changed the fuel filter n PCV valve thats the only thing i can think of or your clutch is gettin weak. hope this input helps

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines
We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.